It is currently 17 Nov 2017 19:13


clutch pressure plate

  • Author
  • Message

cmh2363

clutch pressure plate

Post20 Oct 2017 03:34

looking for clutch pressure plate ive renewed plate thrust bearing and slave cylinder still clutch bites right at bottom whith no play atall please help .shadracks@hotmail.co.uk M/N 3963 THANKS :oops:
Offline

Keith Bennett

  • Posts: 2293
  • Joined: 20 Sep 2012 18:11
  • Location: Banbury, north Oxfordshire

Re: clutch pressure plate

Post20 Oct 2017 11:46

I'm sure someone on here will have had the same problem in the past and I hope they'll be able to help you.
Offline

Chairman Ed

  • Posts: 634
  • Joined: 03 Oct 2012 16:24

Re: clutch pressure plate

Post02 Nov 2017 03:53

If you need a new clutch, give spares man Derek A call. He sourced a new one for me.

I recall member Steve Stone had a clutch problem and found that the wrong length of rod had been used in the slave cylinder.

I hope we can help you fix the problem.
Offline
User avatar

stoney13

  • Posts: 949
  • Joined: 25 Sep 2012 19:13
  • Location: weston-super-mare, somerset:cyder country

Re: clutch pressure plate

Post15 Nov 2017 11:32

i had the same problem for years, i always thought it was because i was using a race clutch, and the bite was on the floor.
i recently replaced the engine and as you do and replace the clutch, pilot bearing, first motion shaft bearing ( i replaced the gear box as well) thrust bearing, slave cylinder and master cylinder, and it was still the same i checked the rod it was the same length that was fitted to the other box and still it was on the floor, then i seemed to remember that my old cortina had an adjustable rod on the slave to the fork in the gearbox, so having pushed the pedal down and with some wood and jammed it there i got underneath and have a look see and to my surprise the piston in the slave was at full travel up against the circlip so with a tyre lever i pushed against the fork and it went back another 1/2"-3/4" well that would do it so removed the wood from pedal and removed the rod, ho by the way i renewed the the pin in the rod/fork with a larger pin via drilling the fork and rod this is before i found the travel in the piston to be wrong. anyway now i have the rod off i cut a bolt to a length of 1/2" and welded it to the rod fitted it back and hey presto i have full travel on the pedal and it bites about half way up, the next thing to do is to remove it again and make it adjustable, oh by the way i replace all the cotter pins and replace the split pins with R clips available from most model shops for a few pence sorry for the long answer but i thought its worth a shot ;)


Last bumped by Guest on 15 Nov 2017 11:32.
EMA KAY - K- zoid racing ( A40 s/w group & Avon Austineer)

Return to CLUB SPARES SCHEME

Who is online

Users browsing this forum: No registered users and 1 guest

cron